Skip to end of metadata
Go to start of metadata

This page provides a snaphot of the compatible release versions of each Ribbon device that can interoperate with the Ribbon Secure Telephone Identity (STI). The latest compatible release versions listed in the table represent the latest compatible (supported) releases as of the STI GA (General Availability) date. 

If your network includes Ribbon devices with newer release versions than what is listed in the table, refer to the Ribbon device's Interoperablity Matrix to see which STI versions are compatible with the newer releases of the Ribbon devices.


IMPORTANT

If you are upgrading to a sustaining/maintenance release, refer to the product release notes for additional interoperability details.


Note

The Interoperability tables are intended to list supported releases, not necessarily tested releases. Ribbon lists tested releases in the appropriate Release Notes for each version.

Note

When a release branch does not specify any R-buld versions, all versions are supported for that branch. Additionally, the GA dates represent the dates of the most current release.


The example below demonstrates choosing an upgrade strategy for STI, EMS and PSX: 

When planning to upgrade to STI release 21.04.00R000, also upgrade to the latest PSX 13.02.01R000 and EMS 13.02.02R000 releases to ensure full new feature functionality introduced in STI release 21.04.00R000.
(Reference: first table below)

  • Backwards compatibility: STI 21.04.00R000 is compatible with PSX/EMS releases back to PSX 11.02.04R002 and EMS 13.01.00R00; however, the new STI 21.04.00R000 features and functionality is not available when using the older PSX/EMS releases.
  • Newer supported release version: If you wish to use a newer PSX release, such as 14.00.00R000, it is important to consult the PSX Interopertability Matrix to determine which STI releases are compatible with PSX 14.00.00R000.
    • The reason for this is that:
      • when a product is released, its Interop. Matrix is a snapshot in time to define the supported release versions. 
      • when an associated product gets released at a later date, that Interop. Matrix reflects the supported product releases (as a future snapshot in time) against that newer release. 


Table : STI Compatibility Matrix Example

STI VersionCompatible Ribbon Product Versions
ReleaseGA
PSXEMS
21.04.00R000

 

Latest13.02.01R000
13.02.02R000
Minimum11.02.04R00213.01.00R000
20.12.00R000

 

Latest13.01.00R000
13.02.00R000
Minimum11.02.04R00213.01.00R000
20.08.00R000

 

Latest13.00.00R00013.01.00R000
Minimum11.02.04R00213.01.00R000

Table : PSX Interoperability Matrix Example

PSX VersionCompatible Ribbon Product Versions
Release:GA
VNFMSTI
14.00.00 Latest20.1.021.04.00R000
Minimum2018.3.020.09.00R000
13.02.xx Latest20.1.0

20.12.00R000

Minimum2018.3.020.09.00R000
13.01.00 Latest20.1.020.09.00R000
Minimum2018.3.020.09.00R000


STI

The following table depicts the Ribbon product release versions that support the Ribbon STI. Two software releases (labeled as Latest and Minimum) of each Ribbon product are associated with each STI release version in the table.

  • Latest release indicates the product release version to use to ensure interopterablity with the latest STI features and functionality.
  • Minimum release indicates the oldest compatible product release version.

LEGEND

N/A : Not applicable

N/T: Not tested


STI Compatibility Matrix (Beginning with 20.06)

STI VersionCompatible Ribbon Product Versions
ReleaseGA
PSXEMS
21.09

 

Latest14.00.00R00014.00.00R000
Minimum11.02.04R00213.01.00R000
21.07

 

Latest14.00.00R000
14.00.00R000
Minimum11.02.04R00213.01.00R000
21.04

 

Latest13.02.01R000
13.02.02R000
Minimum11.02.04R00213.01.00R000
20.12

 

Latest13.01.00R000
13.02.00R000
Minimum11.02.04R00213.01.00R000
20.09

 

Latest13.01.00R000
13.01.00R000
Minimum11.02.04R00213.01.00R000
20.08

 

Latest13.00.00R00013.01.00R000
Minimum11.02.04R00213.01.00R000
20.06

 

Latest13.00.00R000N/A
Minimum11.02.04R002N/A