Search

Page tree
Skip to end of metadata
Go to start of metadata

In this section

Overview

To parse and analyze a log file, simply open the file with Log Exchange (LX). By default, no SIP messages or IP addresses are excluded, so all SIP messages are included in the log from every peer connected to SBC systems or VX. However, no module errors exist in the log as these are off by default.

Multiple instances of the LX can be run to listen for syslogs in different ports, IPs, and transports without any performance impact.

Menu Options

Figure : LX Syslog Server

 

Table : Menu Bar Options

 
Menu OptionDescription/Options
Start ListeningBegins listening to SBC or VX system
Stop ListeningStops listening to SBC or VX system
AnalyzeAnalyzes syslog file
Save FileSaves syslog file
Clear MessagesClears syslog file
CopyCopies syslog log file
CloseCloses syslog Server
Save to Disk

Saves syslog file to disk.

The log destination is determined in the settings, see Working with Settings and Filters

Listen IPSpecifies IPv4 and IPv6 for the LX system
TransportSpecifies method of transport: TCP or UDP
Listen Port

Specifies port to use on the LX system

Syslog Filter

Indicates if 5K/7K Syslog Live Filtering has entries to exclude SIP methods

Filtering is determined in the settings, see Working with Settings and Filters

Opening Saved Log Files

There are three methods of opening a saved log file ( filename.log ) in LX:

  • In the File menu, click Open and browse for the file.

    Or use the keyboard shortcut and browse for the file.

  • Drag the file's icon onto the LX User Interface.

  • Double-click the file's icon.

Copying Syslog Files

Use a text editor associated in Windows to copy the current Syslog Server buffer to a text .txt file.

If the .txt file is not specifically associated with any other application, Windows will automatically use Notepad.

Figure : Copying Syslog Files

 

To copy the current buffer to a text editor:

  1. In the LX Syslog Server window, click Copy.

The contents of the syslog buffer are copied and opened in the associated text editor the instant you click Copy.

The syslog buffer continues to capture log entries as they come from the SBC system, and none of the copied content is lost.

Figure : Notepad

 

Analyzing LX Syslog Server Captured Messages

Figure : Analyze Calls

 

To begin analyzing captured syslog messages

To exclude a SIP Method or IP address configure settings before analyzing. For more details, see Working with Settings and Filters.

  1. In the LX Syslog Server dialog

    1. Click Stop Listening, then

    2. Click Analyze.

Syslog File Management

Use Syslog File Management for a real time view on the current state of the syslogs in the file directory, and to open, analyze and delete files. The file directory is set under Syslog Server Settings (see working with Working with Settings and Filters).

 

The active file appears in red; all other files appear in black.

Figure : Syslog File Management

 

Syslog Separator for Multiple Clients

Use the Syslog Separator to separate the syslog data received from multiple clients.

Make sure to set up a Log Destination before preforming this procedure. For more information, see Working with Settings and Filters

To separate a log file

  1. Go to Tools > Syslog Separator in the menu bar

  2. Click Browse and select log file

  3. Click Separate

When the Syslog Separator is complete, new files will appear under their appropriate folders.

Figure : Syslog Separator

 

Syslog Loss Analyzer

Use the Loss Analyzer feature to inspect log file and determine whether or not there are missing log lines.

This feature is only supported for SBC Edge (1000/2000/SWe Lite) log files.

To examine a log file

  1. Go to Tools > Syslog Loss Analyzer in the menu bar
     

  2. Click Browse and select log file

  3. Click Open

  4. Click Analyze

Figure : Loss Analyzer