Application Note - MultiPath Routing

This document gives you a detailed description of the new MultiPath Routing capabilities in a Tenor VoIP system.

The following topics are included in this Application Guide:

- Overview - What is MultiPath Routing?
- Configure MultiPath Routing
- MultiPath Routing - Configuration Examples
- MultiPath Routing - Basic Call Flow Examples
- MultiPath Routing - Specialty Call Flow Examples
Overview - What is MultiPath Routing?

The Tenor has enhanced its routing capabilities by offering new MultiPath Routing. When the Tenor is connected to the PBX, PSTN and IP, it can translate incoming Called and Calling numbers based on digits, pattern, and length. The flexibility of the routing method supports any-to-any routing (i.e, IP-to-IP) and flexibility in call translation.

How does MultiPath Routing work?

Once MultiPath routing is enabled, the configuration in the Routing Table is applicable to all calls. Routing will be accomplished according to the configuration in the Routing Table and Number Table. For a new call, the Tenor will always attempt to route the call using the existing DN Channel Map (DNCM). If further routing is required, the Tenor will look to the MultiPath Routing table for call matches (i.e., calling/called numbers) and then to the Number Table for call translation patterns, replacement numbers, etc.

If the Routing table is not configured, the Tenor will fall back to traditional routing (DNCM, Hop Off, HuntLDN).

DN Channel Map Based Routing

Any incoming call into a Tenor (From IPRG, TCRG or LCRG) will check the Dialed Number Channel Map (DNCM). If it finds one or more entries in the DNCM, it searches through the DNCM entries to find a match.

- If the DNCM entry is associated with an LCRG, it will be matched against the Called (destination) number received.
- If the DNCM entry is associated with an TCRG, it will be matched against the Calling number received.

If a match is found, the Tenor uses the corresponding channel to send the call out. If the Tenor cannot find an exact match in the DNCM, the call is routed using the new Routing Table.

Analog

Analog (FXS). Calls originating from an FXS channel (LCRG) will use the corresponding entry in DNCM as the Caller ID. After collecting the destination number, DNCM-based routing will be used. If a match is not found in the DNCM, the new Routing Table will be used.

Analog (FXO). Calls originating from an FXO channel (TCRG) will use the corresponding entry in DNCM as the called (destination) number. The Caller ID is received through the FXO line, if available. DNCM based routing will be used. If a match is not found in DNCM, the Routing Table will be used.

Digital

Digital (Loop Start). If Loop start is used, calls originating from an FXS channel (LCRG) will use the corresponding entry in DNCM, as the Caller ID. After collecting the destination number, DNCM based routing will be used. If a match is not found in DNCM, the new Routing Table will be used.
Digital (PRI, E&M, R2). If PRI, E&M or R2 signaling is used, the calling number and called number are received through the digital interface. DNCM-based routing is used; if no match is found in DNCM, the Routing Table will be used.

Configuration Basics

All the configuration for new MultiPath Routing is completed through the Tenor Configuration Manager or the Command Line Interface (CLI).

When new MultiPath routing is enabled, the bulk of the configuration is done through new Routing tables. Also, the following configuration fields are not applicable and are greyed out in the Tenor Configuration Manager:

VoIP Configuration

• Gateway Tab: Modem Bypass Retention Hours

SIP Signaling Group

• Direct Gateway Routing

LCRG

• General Tab: Pass Through, Pass Through ID, External Routing
• Trunk/Caller ID Tab: Outbound ANI Number Digits, Add End of Dial Digit
• Advanced Tab: Modem Bypass

TCRG

• General Tab: Pass Through, Pass Through ID, External Routing, Busy Out
• Trunk/Caller ID Tab: Outbound ANI Number Digits, Add End of Dial Digit
• Advanced Tab: Forced Routing Number Type, Forced Routing Number, Modem Bypass

IPRG

• Advanced Tab: Ignore TON NPI, Enable External Routing
• ANI Tab: Relay ANI, Default ANI, Default ANI Screen Indicator, Default ANI Presentation Indicator

ISDN Signaling Group

• Advanced Tab: Relay ANI, Default ANI, Default ANI TON, Default ANI NPI, Default ANI Screen Indicator, Default ANI Presentation Indicator
Configure MultiPath Routing

Getting Started

For the purposes of this document, all configuration for the Tenor is completed through the Tenor Configuration Manager software, available at www.quintum.com.

These instructions assume the Tenor Configuration Manager is downloaded, installed and running. For detailed information about how to install the software, see the Tenor Configuration Manager User Guide. Basic configuration parameters for each of the required fields is included in this document; detailed information is available in the Command Reference guide.

Step 1: Enable MultiPath Routing

NOTE: Once the Routing type is changed and submitted (i.e., Use Routing Table is checked/enabled), the database settings unrelated to the Routing Table feature will be DELETED permanently. Before you enable the New Routing, it is recommended that you BACKUP and SAVE all the Tenor’s database files before you continue.

NOTE: To backup a database, from the Tenor Configuration Manager’s main menu, select Tools > Backup. See the Configuration Manager User guide for information.

1. From the main menu tree on the left side of the window, select VoIP Configuration > Gateway.

2. Check the box Use Routing Table.

3. Click Confirm/Ok. A warning box will alert you to backup and save the Tenor’s database files before proceeding. Click Ok.
4. Click on Confirm/Ok.

5. From the main Tenor Configuration Manager window, click on File > Submit Changes. Click Ok. The change is submitted to the Tenor. The Routing Table and Number Tables are listed in the main menu. See Step 2: Configure Number Table and Step 3: Configure Routing Table.

**Step 2: Configure Number Table**

**NOTE:** The Routing Table populates the options in the Called Number and Calling Number fields from the Number Tables available. As a result, it is recommended that you add/configure the Number Tables before configuring the Routing Table.

The Number Table includes call definitions that the Routing Table uses for called and calling number information. For each call route, you are able to add/select a Number Table that is used to translate that calling/called information. For example, in the Call Flow Examples (see Multi-Path Routing - Basic Call Flow Examples), a number table “Number Table-Called” is added to define the pattern, replacement, etc. for outgoing calls from the Tenor. A maximum of 32 tables can be added; a maximum of 32 entries is allowed per table.

The configuration detailed here applies to the Number Table-Default table, which is already created. To add a new Number Table, (i.e., NumberTable-Called), right-click on Number Table from the main menu tree, select New, and enter the desired name in the Number Table box.

Configure the Number Table as follows:

1. From the main menu tree, select VoIP Configuration> Number Table> Number Table-default.

2. Click on the Add button. The Add Number Table Entry window is displayed.

**NOTE:** For a quick way to Add, Edit, Delete an entry, or move an Entry Up or Down in the table, right-click on the Table and select the desired option.
3. Configure the appropriate options for each Number entry. These configuration options will be used to match the called/calling numbers for incoming calls. See below for field definitions:

- **Incoming Pattern.** Incoming matching Pattern. Valid entries 0 - 9, #, + (only as a beginning character), '.' (placeholder for any single character, '*' (at beginning or end of the string means wildcard), '*' (in middle of string means '*' character), [ ] represents a range. (i.e. [3-9] indicates that the character can be any number from 3 through 9). Up to 31 character string.

- **Outgoing Pattern.** By default, this is the outgoing replacement number. If the Called Number for Diversion is set in the Routing Table, the Outgoing Pattern field is used in the Diversion header of the outgoing Setup/Invite.

  If the Incoming Pattern field is a range, represented by [ ], then a '.' in the Outgoing Pattern field means the number will be replaced with the same number.

  If the number in the Outgoing Pattern field is to be sent “as is” without translation, the same number as in the Incoming Pattern field should be entered. If the Outgoing Pattern field is blank, nothing will be sent out.

  Allowed entry: up to a 31 character string.

- **Type of Number (TON).** Type of number used for replacement. Select from the drop down list.
• **Numbering Plan Indicator (NPI).** Number Plan Indicator used for replacement. Select from the drop down list.

4. Click on **OK**.

5. If desired, in the description box, enter a description for the Number Table. This description can include a name for the call route.

6. Click on **Confirm/OK.** The entry is saved to the Number Table.

7. To edit an entry, click on **Edit** and make changes in the *Edit Number Table* window and click **Ok.** To delete an entry, click on **Delete** and the entry will be deleted.

8. From the main *Tenor Configuration Manager* window, click on **File > Submit.** The changes are submitted.

**Step 3: Configure Routing Table**

The Routing Table translates the incoming Called and Calling party number. After DN Channel mapping, the Tenor will check to see if the Routing Table is configured and if so, routing will be done using the definitions in this table, along with the configuration in the Number Table.

1. From the main menu, select **VoIP Configuration > Routing Table** (Ensure the **Use Routing Table** option is enabled or the Routing Table option will not be visible in the Main Menu. See **Step 1: Enable MultiPath Routing**).

2. Click on the **Add** button. The *Add Routing Table Entry* window is displayed.

**NOTE:** For a quick way to **Add, Edit, Delete** an entry, or move an Entry **Up** or **Down** in the table, right-click on the Table and select the desired option.
3. Configure the appropriate options for each incoming call. These configuration options will be used to match the called/calling numbers for incoming calls. The table can hold a maximum of 32 entries. See below for field definitions:

- **Incoming From.** Indicates how the call is received. Select from the available options. * indicates the call is received on any trunk group.
- **Outgoing To.** Indicates how the call is sent. Select from the available options.
- **Incoming Match Criteria.** Indicates how the incoming call is matched: Called Number or Calling Number.
- **Called Number Table.** Select the Number table used for number matching/translation (this list is generated from the available Number Tables). An empty table indicates that no Called Number table is used.
- **Calling Number Table.** Select the Number Table used for number matching/translation (this list is generated from the available Number Tables). An empty table indicates that no Calling Number table is used.
- **Diversion Match Criteria.** The Called Party number that is put in the outgoing call. If there is an entry in this field, the outgoing message will have a Diversion Header (which contains the called number from the original message). The called number in the outgoing number will contain the phone number defined in this field. Relevant for SIP outbound calls. Default entry: none.
**Diversion Pilot (Called) Number.** Defines whether the entry is called or calling. If this field is non-blank, it controls (in the case of Diversion) whether there will actually be a diversion header in the outgoing message. The called number in the outgoing number will contain the phone number that is defined in the Call Number for Diversion field.

If Diversion Content is Called and there is no match on the called number, a diversion header is not added to the outbound message. If Diversion Content is Calling and there is no match on the calling number, a diversion header is not added to the outbound message.

In these no match cases, the outgoing called number will be replaced by the value in the **Diversion Match Criteria** field, but a diversion header is not added to the outbound message.

Default entry is blank.

4. Click on **Confirm/Ok**. The entry is saved to the Routing Table. If you click on **Called Number Table** or **Calling Number Table**, the Number Table window is displayed.

5. To edit entry, click on **Edit** and make changes in the **Routing Number Table** window and click **Ok**. To delete an entry, click on **Delete** and the entry will be deleted.

6. To move the entries up or down in the table, click on **Up** or **Down** at the top of the main window.

7. To move the entries up or down, click on **Up** or **Down** at the top of the main window.

8. From the main **Tenor Configuration Manager** window, click on **File > Submit Changes**. The change is submitted to the Tenor.

**Step 4: Configure additional options**

Along with the Number Table and Routing table, there are a few new additional configuration options the can be used in MultiPath Routing (they are also used with traditional routing).

- **SIPSIG.** For SIP (SIP Signaling Group), the **TransportType** is now controlled from the SIPSIG (From the **Tenor Configuration Manager**, click **SIP Signaling Group > SIP Signaling Group -1 >Advanced**). Select from the **Transport Type** drop down list: **UDP** or **TCP**.
  This can be changed on a per SIPSIG basis.

- **IPRG.** An IPRG can now be attached to a SIP Signaling Group (From the **Tenor Configuration Manager**, click **SIP Signaling Group > SIP Signaling Group -1 >General**) and select an IPRG from the IP Routing Group drop down list. Click on **Confirm/Ok**. From the main **Tenor Configuration Manager** window, click on **File > Submit Changes**. The change is submitted to the Tenor.
MultiPath Routing - Configuration Examples

Number Table

To set up the call flows described in the next section (see *MultiPath Routing - Basic Call Flow Examples* and *MultiPath Routing - Specialty Call Flow Examples*), add and configure the numbering tables which follow. For example, create a Number Table entitled “NumberTable-Called” with the configuration listed (*Figure 1-4*). See Step 2: Configure Number Table for how to add a Number Table and configure the parameters through the Tenor Configuration Manager.

*Figure 1-4* Number Table-Called Example

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Replacement</th>
<th>Type of Number</th>
<th>Numbering Plan Indicator (NPI)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1732460*</td>
<td>*</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>555...</td>
<td>555...</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>1732432*</td>
<td>432*</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

*Figure 1-5* Number Table-Calling Example

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Replacement</th>
<th>Type of Number</th>
<th>Numbering Plan Indicator (NPI)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1610*</td>
<td>1732*</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>*....</td>
<td>....</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

*Figure 1-6* Number Table-VoiceMailDiversion Example

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Replacement</th>
<th>Type of Number</th>
<th>Numbering Plan Indicator (NPI)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1506*</td>
<td>1302*</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>
**Figure 1-7** Number Table-Forwarding1 Example

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Replacement</th>
<th>Type of Number</th>
<th>Numbering Plan Indicator (NPI)</th>
</tr>
</thead>
<tbody>
<tr>
<td>15062341111</td>
<td>+13022341111</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

**Figure 1-8** Number Table-Forwarding2 Example

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Replacement</th>
<th>Type of Number</th>
<th>Numbering Plan Indicator (NPI)</th>
</tr>
</thead>
<tbody>
<tr>
<td>15062342222</td>
<td>+13022342222</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

**Routing Table**

See *Step 3: Configure Routing Table* for how to configure the options in the Routing Table through the Tenor Configuration Manager.

**Figure 1-9** Routing Table Configuration Example

<table>
<thead>
<tr>
<th>Incoming From</th>
<th>Outgoing To</th>
<th>Incoming Match Criteria</th>
<th>Called Number Table</th>
<th>Calling Number Table</th>
<th>Diversion Match Criteria</th>
<th>Diversion Pilot (Called) Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Circuit</td>
<td>ua-101</td>
<td>Calling</td>
<td>-</td>
<td>NumberTable-Calling</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Circuit</td>
<td>ua-102</td>
<td>Called</td>
<td>NumberTable-Called</td>
<td>Number Table-Calling</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>SIP</td>
<td>tcrg-2</td>
<td>Called</td>
<td>NumberTable-Called</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>SIP</td>
<td>lcrg-1</td>
<td>Called</td>
<td>-</td>
<td>NumberTable-Calling</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>H.323</td>
<td>ua-101</td>
<td>Called</td>
<td>NumberTable-Called</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Circuit</td>
<td>ua-102</td>
<td>Called</td>
<td>NumberTable-Voice-MailDiversion</td>
<td>-</td>
<td>15067671111</td>
<td></td>
</tr>
<tr>
<td>Circuit</td>
<td>ua-101</td>
<td>Called</td>
<td>NumberTable-Forwarding1</td>
<td>-</td>
<td>1111</td>
<td></td>
</tr>
</tbody>
</table>
MultiPath Routing - Basic Call Flow Examples

Using the entries configured in the Number Table and Routing Table (see MultiPath Routing - Configuration Examples), this section details how the routing configuration is used to complete the following basic call flows.

PSTN to SIP Call

NOTE: All call matches are listed in top down priority order.

A call coming into the Tenor from the PSTN and destined for IP (SIP), has a called party number of 17324609000 and a calling party number of 16105551212. The call proceeds to as follows:

First Match Attempt

- The first successful match is with row #1 in the Routing Table. **16105551212** matches the Calling number matching pattern of **1610* in NumberTable-Calling.**
- The call goes out SIP using **ua-101.**
- The outbound Calling number is translated to **17325551212.**
- There is no Called number translation.

Second Match Attempt

- If the call for match #1 fails, a second attempt is made to the route specified in row 2 of the Routing table. **17324609000** matches Called number matching pattern **1732460* in NumberTable-Called.**
- Outgoing call goes out SIP using **ua-101.**
- The Called number is translated and the To/From Request URI is 9000.
- The Calling number is translated and the From header is **17325551212.**

SIP to PSTN (or PBX) Call

NOTE: All call matches are listed in top down priority order.

A call coming into the Tenor from IP (SIP) has a Request URI (Called Party) of 555111 and a From URI (Calling Party) of 7322345678. The call proceeds as follows:

First Match Attempt

- The first successful match will be with row #3 in the Routing Table. **5551111** matches the Called number matching pattern of **555.... in NumberTable-Called.**
- The call goes out PSTN using **tcrg-2.**
- There is no Called or Calling number translation.

Second Match Attempt
• If the call for Match #1 fails, then a second attempt will be made to the route specified in row 4 of the Routing Table. 5551111 matches Called number matching pattern 555....
• For this route, the outgoing call will go out using lcrg-1.
• The Calling Number (From header) is translated and the resulting Calling number is 5678.

H.323 > SIP Call (IP to IP call)

NOTE: All call matches are listed in top down priority order.

A call coming into the Tenor from IP (H323) has a Called Party of 17324322222 and a Calling Party of 19142223333. The call proceeds as follows:

• The first successful match will be with row #5. 17324322222 matches the Called number matching pattern of 1732432* in NumberTable-Called.
• The call goes out SIP using ua-101.
• The Called number is translated and the resulting To/Request URI is 4322222.
• There is no Calling number translation.

MultiPath Routing - Specialty Call Flow Examples

Using the entries configured in the Number Table and Routing Table (see MultiPath Routing - Configuration Examples), this section details how the routing configuration is used to complete the specialty call flows which follow:

NOTE: All call matches are listed in top down priority order.

OCS- Voice Mail Diversion

A call comes in from the circuit side with a Calling Party Number of 15069871234 and a Calling Party Number of 14101234987.

• The first successful match is with row #6 of the Routing Table. 15069871234 matches the Called number matching pattern of 1506* in NumberTable-VoiceMailDiversion.
• The call goes out SIP through ua-102 and the resulting To/Request URI is 15067671111.
• The From header is 14101234987 (no translation).
• The Diversion header = 13029871234.

OCS - Call Forwarding

A call comes in from the circuit side with a Calling Party Number of 14102223333 and a Called Party Number of 15062341111.

• The first successful match is row #7. 15062341111 exactly matches the Called number matching pattern in NumberTable-Forwarding1.
• The call goes out SIP with ua-101 and the resulting To/Request URI is 1111.
• The From header is 14102223333 (no translation).
• The Diversion header is +13022341111.